• 公告栏使用li标签,同时你可以使用FontAwesome以及其他HTML语法
  • FontAwesome示例
  • 不必为自己的独特看法而害怕, 因为我们现在所接受的常识都曾是独特看法@《自由思想的十诫》罗素 (哲学家 数学家)

FreeBSD 10: Installing Apache 2.4, MySQL 5.5, and PHP5.5 — 找不到 libphp5.so

*BSD shaobo 35次浏览 573字 0个评论

今天装freebsd 10,然后装apache,再装php和php扩展.没有问题.

然后重启apache,发现打不开php页面,提示下载.

刚开始以为php5安装错误了,于是又重新安装一次,发现安装php5时里面没有apache选项了,整了半天也没有发现原因,以前用freebsd8配置apache+php+mysql从来没出现过这种问题,就再试一下php53目录,make config-recursive看看里面是有apache选项的,郁闷,于是又出墙google,终于找到答案了,ls /usr/local/libexec/apache22/ 没找到libphp5.so

然后/usr/ports/www/mod_php5

make install clean;rehash安装,可是又遇到问题了,提示“Error from bsd.apache.mk. apache22 is installed (or APACHE_PORT is defined) and port requires apache”,郁闷之极,只能再google,呵呵,又被我找到答案了,万能的google啊,谢谢!关于“Error from bsd.apache.mk. apache22 is installed (or APACHE_PORT is defined) and port requires apache"请参考这篇文章


喜欢 (0)

您必须 登录 才能发表评论!